AnsweredAssumed Answered

JSON Webhook not actually firing

Question asked by 400a4f0782eb3328af3a4b79643916824d80e02c on Jan 12, 2017
Latest reply on Jan 16, 2017 by 400a4f0782eb3328af3a4b79643916824d80e02c

Hi all

 

Having some trouble with a JSON webhook I'm trying to run through Marketo and Zapier. Here's the code:

 

URL: (what Zapier gave me)

Request Type: POST

Template: {"first name": "{{company.First Name (A):default=edit me}}","last name": "{{company.Last Name (A):default=edit me}}", "billing address": "{{company.Billing Address:default=edit me}} ", "billing city": "{{company.Billing City:default=edit me}}", "billing country": "{{company.Billing Country:default=edit me}}", "postcode": "{{company.Billing Postal Code:default=edit me}}"}

Request Token Encoding: None

Response type: None

Custom Headers: Content-Type, application/json

 

Unfortunately nothing seems to be received by Zapier. I also tried with Request Bin and got nothing after running some sample leads through a smart campaign. But when I run identical code through Postman (changing the token fields to be hardcoded values) it works like a charm.

 

I noticed in another thread that Marketo automatically puts quotes around tokens when the encoding type is JSON, so I changed it to "None". But this doesn't seem to make a difference. Can anyone see what I'm missing here? I'm sure it's something simple!

 

Thanks in advance.

 

Phil

Outcomes